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LAB 24 - Widening and Overlay

Widening and overlay projects are an increasingly large part of the CDOT workload. This lab illustrates the 
MicroStation and InRoads tools used for projects that require pavement widening, overlay, and pavement 
milling (stripping in InRoads terminology).

In conjunction with overlay and stripping components a slope optimization function is available to constrain  
transverse design slopes relative to existing conditions. This utility can be utilized for design development 
whether the design template contains standard components or the new overlay and stripping components 
introduced with the SELECTseries release of InRoads.

Chapter Objectives: 

 Create a complex chains for the pavement edges from existing ground features.

 Import the chains as horizontal and vertical alignments.

 Develop a slope optimization solution.

 Develop a widening and overlay template.

 Define corridors for the project.

 Model the corridor and apply slope optimization.

 Model the corridor with overlay and stripping components.

The Following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model_Overlay.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Geometry_Overlay.alg

 C:\Workspace\Workspace-CDOT_V8i\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground-Overlay.dtm

This project runs the length of the SH 86 alignment from station 205+00 to 259+00. Therefore, the display of 
features, etc. will be restricted to an area from station 204+00 to 260+00. This will ensure that enough data is 
available for the full length of the project.

Note: The first two labs in this chapter illustrate a workflow to develop horizontal and 
vertical alignments which represent the left and right edges of existing pavement. 
These alignments can be used as point controls on widening projects if the proposed 
design must vary width, elevation, or both, relative to the existing roadway.  
A slope optimization utility is also available which offers additional flexibility for 
vertical design development.  If the design calls for it, point controls can be used to 
constrain the design template to the existing pavement width.  Also the template can be 
constrained vertically based on user defined delta tolerances between the design 
template cross slope and  the existing cross slope. Allowing the designer flexibility to 
match existing conditions (0% tolerance) or to define slope deviation as a user input for 
maximum delta tolerance.
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Lab 24.1 - Chain Pavement Edge Features

As single continuous lines are easier to use for point controls than a number of unconnected 
lines. Creating the complex chain also provides the opportunity to close gaps in the pavement 
edge features. 

1. Open MicroStation and InRoads using the C:\Projects\12345\Design\Drawings\ 
Reference_Files\12345DES_Model_Overlay.dgn file.

2. Load the following files into InRoads:

♦ C:\Projects\12345\Design\InRoads\12345DES_Geometry_Overlay.alg
♦ C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground-

Overlay.dtm
♦ C:\Workspace\Workspace-CDOT_V8i\Standards-Global\InRoads\ 

Templates\CDOT_Template-Library.itl

3. Verify that the C:\Workspace\Workspace-CDOT_V8i\Standards-Global\ 
InRoads\ Preferences\CDOT_Civil.xin file is loaded.

The first step is to mark out the limits of construction. Then a MicroStation fence is used to 
limit InRoads displays to this area.

4. In the InRoads explorer, <D> the Geometry tab.

5. <R> on the SH 86 horizontal alignment and select View from the right click menu.

6. Select Fit View from the MicroStation view controls.

7. From the CDOT Menu, select the Drafting group.

8. <D> the Border button.
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9. Highlight Clip Boundary from the item list. This activates the Place SmartLine 
command.

10. In the MicroStation key-in window, key in so=204+00,500 and press Enter.

11. Key in so=204+00,-500 and press Enter. <R> to finish the line.

This places a line perpendicular to the alignment at the beginning of the project.

12. The Place SmartLine command is still active. Key in so=260+00,500 and press 
Enter.

13. Key in so=260+00,-500 and press Enter. <R> to finish the line.

14. From the MicroStation Main toolbar, <D> Place Fence.
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15. In the Tool Settings dialog box, set the Fence Type to Shape. 

16. <T> then <D> to the ends of the lines. The fence is shown in the illustration below.

Next, a feature filter is set up that will only display edge of pavement features. In this case these 
features are named T-Edge of Oil.

17. From the InRoads menu bar, select Surface > Feature > Feature Selection Filter.

18. From the Feature Selection Filter dialog box, toggle on None for the Start With option.

19. Verify that the Attribute is set to Name.

20. Key in T_Edge of Oil* for the Value.

21. Toggle on Include for the Mode.

22. <D> the Add Rule button.
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23. <D> the Save As button.

24. In the Save Filter As dialog box, key in T_Edge of Oil.

25. <D> The OK button. This creates the filter and dismisses the Save Filter As dialog box.

26. <D> the OK button to dismiss the Feature Selection Filter dialog box.

27. On the InRoads Locks toolbar, verify that the T_Edge of Oil filter is selected and that the 
Feature Filter Lock is turned on.

With the Feature Filter defined and set active, The pavement features needed can now be 
displayed.
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28. Select Surface > View Surface > Features from the InRoads menu bar.

29. In the View Features dialog box, verify that 12345 existing ground-Overlay is set as 
the Surface.

30. Set the Fence Mode to Inside.

31. Hold the Ctrl key and <D> on each of the Parking Lot features to de-select them.

32. <D> the Apply button to display the features inside the fenced area.

Note: If the features do not appear in the MicroStation window, <D> the Fit View from 
the view controls button bar.

33. <D> Close to dismiss the View Features dialog box.

34. From the MicroStation Main toolbar, <D> Place Fence to dismiss the fence that was 
placed earlier.
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Notice that each of the edge of oil features displayed has three gaps and a driveway in it. The 
driveways must be removed and gaps filled in before the pavement edges can be chained 
together. In order for the corridor to function properly, the lines placed to fill in the gaps must 
also include elevation information.

35. Use the MicroStation view controls to zoom in on the area with the driveways.

36. From the MicroStation Main taskbar, select the Partial Delete command.



Page 492 Colorado Department of Transportation

LAB 24 - Widening and Overlay Labs for InRoads V8i

37. <D> on the lines as indicated in the illustration below to remove the driveways.

38.  On the CDOT Menu, select the Design group.

39. Verify that the Status is set to Proposed.

40. <D> the Surface button.

41. Highlight Surface 4 from the item list. This level was selected because of the contrast to 
the features displayed.
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42. <T> then <D> at each end of the gap created in the upper pavement edge line and then <R> 
to exit the place line command.

43. Repeat step 42 for each gap in the pavement edge lines. The illustration below shows all of 
the gaps closed.

The lines drawn are accurate to the surface only at the points where they were snapped to the 
features. To ensure that the lines represent the surface over the length of the line, the InRoads 
Drape Surface command is used.

44. From the InRoads menu bar, select Surface > Design Surface > Drape Surface.

45. In the Drape Surface dialog box, verify that the Destination Surface is set to 12345 
existing ground-Overlay.
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46. Set the Input Mode to Level.

47. Set the Source Level to DES_Surface_4.

48. Set the Destination Level to DES_Surface_3. This level was chosen because its display is 
different from both the lines drawn and the features displayed.

49. Toggle on Delete Original Graphics.

50. <D> Apply. The original lines are deleted and replaced with linestrings on the destination 
level, DES_SURFACE_3. The new linestrings contain a vertex at each point where the 
original line crossed a triangle in the destination surface.

51. <D> Close to dismiss the Drape Surface dialog box.

Now the edge of oil lines can be chained into a single element.

52. Select Fit View from the MicroStation View Controls.

53. From the MicroStation main taskbar, select the Delete command and delete the lines that 
mark the begin and end of the project. This is to ensure that they are not accidentally 
included into one of the chains.
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54. From the MicroStation main taskbar, select the Create Complex Chain command.

55. In the tool settings box, set the Method to Automatic.

56. <D> on the left most element in the top line then <D> in a blank area. All of the elements 
that make up the upper pavement edge highlight.

57. <D> in a blank area to accept the selection set and create a single chain from the elements.

58. <D> on the left most element in the bottom line then <D> in a blank area. 

59. <D> in a blank area to accept the selection set and create the second chain.

Section Summary:
♦ Use Feature Selection Filters to limit the number of features to those needed.

♦ Use a MicroStation fence to further limit what is displayed to the area of the project.

♦ Once displayed, the feature graphics are like any other MicroStation element.

♦ Be careful if the Gap setting is increased for the Create Complex Chain command. 
Increasing the gap could allow the program to grab elements that are not intended to be 
part of the chain.

Lab 24.2 - Creating Alignments from Graphic Chains

Now that the pavement edges have been chained together, these linestrings can be imported as 
horizontal and vertical alignments.These alignments will be used for point controls in a later 
exercise.

Section Objectives:

♦ Import the graphic elements created in the previous exercise as horizontal and vertical 
alignments.
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1. From the InRoads menu bar, select File > Import > Geometry.

2. On the Import Geometry dialog box, verify that the From Graphics tab is selected.

3. Set the Type to Horizontal and Vertical Alignment.

4. In the Name field, key in Lt_EOP.

5. In the Description field, key in Left edge of pavement for point control.

6. Select ALG_OTHER for the Style.

7. Verify that the Geometry Project in the Target area is set to 12345DES_Geometry 
_Overlay.

8. <D> Apply.

9. <D> on the upper chain, then <D> again to accept the selection. <R> to redisplay the 
Import Geometry dialog box.
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10. In the Import Geometry dialog box, key in Rt_EOP for the Name.

11. In the Description field, key in Right edge of pavement for point control.

12. <D> Apply.

13. <D> on the lower chain, then <D> again to accept the selection. <R> to redisplay the 
Import Geometry dialog box.

14. <D> Close to dismiss the Import Geometry dialog box.

15. In the InRoads explorer, <D> the Geometry tab and verify that Lt_EOP and Rt_EOP are 
in the geometry project. 

16. Save the 12345DES_Geometry_Overlay geometry project.

Section Summary:
♦ Take care when importing feature graphics as alignments, overlapping and gaps in 

elements are common and can cause problems in Roadway Designer.

♦ One way to tell if the Import Geometry command worked is to look in the Name field 
after the command was executed. If the last letter in the name has changed, then 
geometry was created.

Lab 24.3 - Cross Slope Optimization - Concept Lab

Specialized tools for overlay and stripping projects have been added to the SELECTseries 
release of InRoads.  Included is a slope optimization utility which redefines the cross slope of a 
template relative to existing conditions. Also new components are available that address 
overlay, pavement leveling, and milling requirements.

The slope optimization utility compares design cross slopes (based on template design and  
superelevation) to the existing ground at template application locations. Based on the Slope 
Tolerance provided by the user, a corrected slope value is calculated for each template drop. 
This information is used to modify the superelevation control line and adjust the template cross 
slope.
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Slope optimization can be utilized if the design profile is coincident to or offset from existing 
ground.

Section Objectives:

♦ Copy the standard template library into the project folder.

♦ Create a new template placeholder.

♦ Add simple components to define the template.

♦ Illustrate the function of the slope optimization tool.

♦ A subsequent lab will utilize slope optimization to model an overlay and widening 
project.

First, the standard template library is copied into the project directory.

1. In the InRoads explorer, <D> the Template tab.

2. <R> on the CDOT_Template-Library and select Save As from the right click menu.

3. In the Save As dialog box, verify that the C:\Projects\12345\Design\InRoads\ 
directory is selected.

4. In the File name field, key in DES12345_Templates-Overlay.
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5. <D> Save then <D> Cancel.

Next, a new template is created in the template library. The template will be very basic to 
illustrate the slope optimization utility however the concept can be applied to any template 
created. 

6. On the InRoads menu bar, select Modeler > Create Template.

7. In the Create Template dialog box, expand the C:\Projects\12345\Design\ 
InRoads\DES12345_Templates-Overlay.itl > 1 - Templates folder.

8. <R> on the 1 - Templates folder and select New > Template from the right click 
menu.

9. Key in 12345_Slope-Optimization for the template name.

10. In the Current Template area, key in 12 FT lane with 2% Cross Slope for the 
Description.

11. Select Tools>Dynamic Settings to display the Dynamic Settings dialog box.

12. In the Dynamic Settings dialog box, key in 0.10 for the X and Y Steps.

13. Toggle on Apply Affixes.
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14. In the Point Name field, select Laneline. The  Point Style is automatically set to  
D_LANELINE.

15. <R> in the template view and select Add New Component > Constrained from the 
right click menu.

16. In the Current Component area, key in DrivingLane-12FT for the Name.

17. Select D_CONC_Pvmt for the Style.

18. <R> in the template view and select Mirror from the right click menu.

19. <D> on the template origin. 

20. In the Dynamic Settings dialog box, key in 12,-2.0% in the hs= field and <enter> to 
build the components.
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21. <enter> a second time to finish the component or <R> and select Finish from the right 
click menu.

This creates two components representing left and right lanes, however, the the template origin 
needs to be renamed.

22. <D><D> on the Laneline point. This displays the Point Properties dialog box.

23. In the Name field of the Point Properties dialog box, key in Centerline and then <D> 
Apply.

24. <D> to dismiss the Point Properties dialog box.

25. Save the template library by selecting File>Save

26. In the Create Template dialog box, <D> Close. 

Lab 24.4 - Creating the Slope Optimized Corridor

A corridor is constructed using the template developed and slope optimization will be applied.

Section Objectives:

♦ Create a corridor for the SH 86 alignment.

♦ Add a template drop using the developed template.

♦ Develop a Superelevation solution for the corridor.



Page 502 Colorado Department of Transportation

LAB 24 - Widening and Overlay Labs for InRoads V8i

♦ Review the superelevation solution in Roadway Designer.

♦ Apply slope optimization to modify the superelevation control lines

♦ Review the revised corridor

This corridor will contain a single template application. Superelevation is required for this 
corridor because of design speed criteria.  However once the superelevation solution is 
calculated it will be modified to minimize the cross slope variation relative to existing 
conditions.

1. From the InRoads menu bar, select Modeler > Roadway Designer.

2. In the Roadway Designer dialog box, select Corridor > Corridor Management from 
the menu bar.

3. In the Manage Corridors dialog box, key in Slope Optimization for the Name.

4. Surface Symbology: D_Surface_1

5. Horizontal Alignment: SH 86

6. Vertical Alignment: SH 86_Existing-V

7. Toggle on Station Limits.

8. Key in 205+00.00 for the Start station.

9. Key in 259+00.00 for the Stop station.

10. <D> Add then <D> Close to dismiss the dialog box.

11. In the Roadway Designer dialog box, select Corridor > Template Drops from the menu 
bar.

12. In the Template Drops dialog box, key in 25.00 for the Interval.

13. Expand the C:\Projects\12345\Design\InRoads\DES12345_Templates-
Overlay template library to show the contents of the 1 - Templates folder.

14. Highlight the 12345_Slope-Optimization template.
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15. <D> the Add button then <D> the Close button to dismiss the Template Drops dialog 
box.

The template is now displayed in the cross section view. Next, superelevation controls are 
added to the corridor.

Calculating the Initial Superelevation

Superelevation is computed to develop a control line along each edge of pavement.  In a 
subsequent command, Cross Slope Optimization, the computed design cross slopes are  
evaluated relative to existing conditions. When developing an optimized cross slope the 
superelevation control lines are copied and modified to develop a revised solution.

Use the Superelevation Wizard:

1. Select Superelevation > Create Superelevation Wizard > Table from the Road-
way Designer menu bar.

2. In the Table Wizard dialog box, <D> the  button to display the Open Superelevation 
Table dialog box.
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3.  In the Open Superelevation Table dialog box, navigate to :
C:\Workspace\Workspace‐CDOT_V8i\Standards‐Global\InRoads\Superelevation 
Tables\AASHTO 2004\ 

 

4. Select 06-55.sup and <D> the Open button.

5. <D> the Load Values From Table button.

The rate values are read from the table and updated for each horizontal curve set listed in 
the dialog box or highlighted.
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6. <D> Next.

7. <D> the ADD button on the Superelevation Section Definitions pane. This displays the 
Add Superelevation Section dialog box.

8. Use the drop down menu or the target  button to select the Crown Point: Centerline.

9. Use the drop down menu or the target button to select the Left Range Point: LT_Laneline.
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10. Use the drop down menu or the target button to select the Right Range Point: 
RT_Laneline.

11. <D> OK.

12. <D> Next on the Superelevation Section Definitions pane. This displays the 
Superelevation Controls pane.

Note: This box lists point controls that are created automatically when you step through 
the Superelevation Wizard. The point controls determine the vertical location (by 
defining a cross slope) of template points (those at and inside the range points) 
while rotating in superelevation.

13. <D> Finish. This completes the development of superelevation for the corridor.
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The Wizard creates superelevation control lines and uses point controls to assign them to  
template points located within the superelevation range.

You will need to process your design to see the superelevation results. Each point control 
corresponds to a control line on the superelevation diagram. 

The superelevation control lines are displayed on the superelevation diagram view in Roadway 
Designer. The control lines represent the percent cross slope (vertical axis) at each station 
(horizontal axis) for each point that is superelevated in the super range.
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14. Toggle between Superelevation and Normal display mode to evaluate the design cross 
slopes vs. the existing conditions along the corridor.

15. In particular review station 231+50

InRoads has developed the design cross slope based on a theoretical superelevation solution. 
Due to the nature of this project it is necessary to minimize the amount of cross slope deviation 
between the design and existing conditions. The slope optimization tool lets a designer add 
overrides to the computed Superelevation solution.

Developing a Slope Optimized Solution

For the following exercise, assume that the desired maximum delta cross slope has been 
determined to be 1.0%.

♦ Slope optimization develops additional control lines based on modifications to the  
superelevation solution developed for the design. The new control lines take 
precedence over the original superelevation solution by automatically disabling the 
original solution.

♦ Slope optimization has to be developed independently for each lane or side of the 
roadway.

♦ Station ranges can be used to isolate curves or set based on the location  of controlling 
features contained in the existing DTM.

♦ Slope optimization may be used whether the design templates contain  overlay/
stripping components or not.

At each template application location the existing ground cross slope is determined by 
computing the delta elevation divided by the absolute distance between the existing pivot point 
and either a feature in the existing DTM or an alignment that represents the existing edge of 
pavement. 
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In the Cross Slope Optimization dialog box, the alignments developed in labs 15.1 and 15.2 
can be used  as the Existing Ground Cross Slope Definition.  However for this exercise, 
features that reside in the existing DTM will be used to illustrate an optional workflow.

By reviewing the physical location of features contained in the existing DTM  it has been 
determined that a solution can be developed between station range 226+55 and 239+75 which 
encompasses a superelevated area of the design.

The left side of the roadway will be processed first followed by the right side.

1. In Roadway Designer toggle on Display Mode: Overlay.

Note: The display mode must be set to Overlay to access the overlay toolset.

2. In Roadway Designer Select Overlay Tools>Cross Slope Optimization.

Enter the following criteria to define the Existing Ground Cross Slope Definition.

3. Existing Type: Feature Name

4. Pivot Feature: T_Traffic Double Yellow 467
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5. Superelevated Feature: T_Edge of Oil497

For the Design Cross Slope Definition select the superelevation control line developed 
previously for the left edge of pavement.

6. Design Type: Control Line

7. Control Line: Section 1 Centerline-LT_Laneline.

8. Key in 1.00% for the Optimization Parameters - Slope Tolerance

9. Toggle on Station Limits and define limits Start 226+55  Stop 239+50.

10. <D> the Calculate Correction button. This computes the cross slope optimization data.
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11. Use the navigation arrows to move between the Adjusted Cross Slopes or to the largest 
adjustment. Notice that the Corrected Slopes are not more than 1.0% different from the 
Ground Slope.

Note: Navigation arrows also exist to review any Delta G values that exceed the 
desirable maximum between stations. This value is not used for computing 
Corrected Slopes and is used for reporting only.

12. Review station 231+50. The Corrected Slope (-4.06%)  is equal to the existing Ground 
Slope (-5.06%) less the specified Slope Tolerance (1.0%). 

13. Select Report to generate an XML report for the solution.  

14. Select the Cross Slope Optimization > CrossSlopeOptimizationStations.xsl style 
sheet.
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15. Dismiss the report after reviewing.

Note: If it’s determined the solution is not valid, selecting Reset Results will clear the results 
grid.

The new cross slopes have been computed based on the existing cross slope and the allowable 
Slope Tolerance. Edits to the corrected values can be made at this time if necessary. Once the 
new control line is saved edits can also be made to the new control line as with any other 
superelevation control line. Also note that the solutions are applied at template locations as 
defined in the corridor. As you navigate between station entries, the Roadway Designer views 
synchronize and both the original and the new control line are displayed in the superelevation 
diagram window.

To create the control line:

16. Under New Control Line, select Section Name: Section 1.

17. For Control Line Name: Key in Slope-Opt_Lt_Laneline.

18. <D> Create.

19. <D> Close to dismiss the Cross Slope Optimization dialog box.
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Review the new control line in the superelevation view and as point controls.

20. Select Corridor>Point Controls to view the added control line. Note that it is 
automatically enabled and the original superelevation control line is disabled.

Note: The Superelevation>Superelevation Report command can also be used to 
review the results. When creating reports include Control Line Definitions to 
verify which control line is being reviewed.

21. Repeat steps 2 thru 18 to develop the solution for the right side of the roadway using the 
following input changes:

♦ In the Existing Ground Cross Slope Definition area, for the Superelevated Feature 
field use T_Edge of Oil511.

♦ In the Design Cross Slope Definition area, for the Control Line field use Section1 
Centerline-RT_Laneline.
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♦ In the New Control Line area, for the  Control Line Name use Slope-
Opt_RT_Laneline.

22. Once the results have been reviewed and confirmed save the roadway definition.

23. From the Roadway Designer menu bar, select File > Save.

24. In the File name field of the Save As dialog box, key in 12345_DES_Overlay.IRD

Section Summary:
♦ The width of the template can be controlled by adding additional point controls or 

through the use of parametric constraints.

♦ Slope Optimization can be used to create a design surface that is vertically offset but 
constrained (parallel or within a delta tolerance) to existing conditions.

♦  A superelevation control line is not a requirement. If matching existing grade, a 
Design Cross Slope of any value can be input. With Slope Tolerance set to 0% the 
Corrected Slope will match existing conditions. 

♦ An Elevation Tolerance can be used in place of a slope tolerance.

♦ Review the point controls created in Roadway Designer. Those created by the 
Cross Slope Optimization tool should be active and the control lines created by the 
superelevation control wizard should not be enabled.

♦ Look for and resolve any conflicting point controls (shown in orange).

♦ Cross Slope Optimization can be used on any template.
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Lab 24.5 - Creating a Overlay Template with Widening

The goal of this lab is to overlay the existing roadway and add paved shoulders outside the 
existing pavement.  In Labs 15.1 & 15.2 alignments were created that represent the existing 
pavement edges.  These alignments will be used as horizontal point controls to maintain the 
existing pavement width.

Note: Stripping and milling are interchangeable terms. They both refer to the uniform 
removal of some amount of pavement material from an existing roadway. InRoads 
menus and reference material use the term stripping.

Section Objectives:

♦ A 2” pavement overlay is required over the existing surface.

♦ 8’ paved shoulders will be added to the outside of the existing pavement.

♦ Existing pavement cross slopes will be maintained.

Note: This template will be modified in a later lab to add stripping and leveling 
components.

A template will be constructed using new components for the overlay portion and existing 
components for the shoulders and sideslopes.

1. Open the Create Template dialog box.

2. Create a new template in the 1 - Templates folder.

3. Key in 12345_Overlay for the template name.

4. Key in 2” overlay with 1” milling & pavement widening for the description.

5. Display the Dynamic Settings dialog box.

6. Key in 0.10 for the X and Y Steps.

7. Toggle on Apply Affixes.
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8. <R> in the template view and select Add New Component > Simple from the right 
click menu.

9. In the Current Component area, key in HMA_Overlay for the Name.

10. Select D_HMA_Pvmt for the Style.

11. Key in 0.1667 for the Thickness. Note: this will round to 0.17 in the dialog box.

12. <R> in the template view and select Mirror from the right click menu.
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13. <D> on the template origin. This creates the two components shown in the illustration 
below.

14. <R> on the vertical line in the center of the template and select Merge Components 
from the right click menu.

15. <D> <D> on the centerline point of the template to display the Point Properties dialog 
box.

16. In the Point Properties dialog box, select HMA_Liftx_Centerline-Top in the Name field. 
This also sets the Surface Feature Style to Centerline.

17. Change the x to a 1 in the liftx part of the name.



Page 518 Colorado Department of Transportation

LAB 24 - Widening and Overlay Labs for InRoads V8i

18. <D> Apply to accept the change.

19. <D> the Next button to select the center bottom point (1).

20. Select HMA_Liftx_Centerline-Top in the Name field. 

21. Change the name and change to read HMA_Lift1_Centerline-Bottom.

22. <D> Apply to accept the change.

23. <D> the Next button to select the right top point (RT_).

24. In the same manner as above, change the name of the point to 
RT_HMA_Lift1_Laneline-Top.

25. <D> Apply to accept the change.

26. <D> the Next button to select the right bottom point (RT_1).

27. Change the name of the point to RT_HMA_Lift1_Laneline-Bottom.

28. <D> Apply to accept the change.

29. <D> the Next button to select the right top point (LT_).

30. In the same manner as done as above, change the name of the point to 
LT_HMA_Lift1_Laneline-Top.

31. <D> Apply to accept the change.

32. <D> the Next button to select the right bottom point (LT_1).

33. Change the name of the point to LT_HMA_Lift1_Laneline-Bottom.
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34. <D> Apply to accept the change.

35. <D> Close to dismiss the Point Properties dialog box. The template looks like the 
illustration below:

Now the shoulders and end conditions are added. 

36. Expand the template library to show the contents of the 2 - Sections - Pavement > 
Shoulder Sections > Hot Mix Asphalt folder. 

37. <D> on the HMA_Outside_Shoulder_3Lifts-12z section.

38. In the Preview window, <D> and hold on the shoulder’s origin (the upper left point).
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39. Drag and drop the section onto the RT_HMA_Lift1_Laneline-Top point.

Note: Because Mirror was turned on when placing the overlay component, both 
shoulders are now placed in the template.

40. <D> <D> on the RT_HMA_Lift1_EOP-Top point to display the Point Properties dialog 
box.

41. The shoulders should be 8’ wide. Change the Value of the Horizontal constraint 
(Constraint 1 in this example) to 8.00.

42. Change the Slope constraint (Constraint 2 in this example) to a Vector-Offset Type.

43. Set the Parent 1 to HMA_Lift1_Centerline-Top.
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44. Set the Parent 2 to RT_HMA_Lift1_Laneline-Top.

45. Repeat for point LT_HMA_Lift1_EOP-Top, using the corresponding points from the left 
side of the template.  Remember to use -8.00 for the value of the horizontal constraint.

46. <D> Apply and then <D> Close to dismiss the Point Properties dialog box.

47. Expand the template library to show the contents of the 3 - Sections - End Conditions 
> Z-Slope End Conditions > High Speed End Conditions folder. 

48. <D> on the Z12_6_to_1 section.

49. In the Preview window, <D> and hold on the section’s origin (the upper left point).

50. Drag and drop the section onto the RT_HMA_Lift1_EOP-Top point.

51. This completes the template. Select File > Save from the Create Template menu bar.

52. <D> Close to dismiss the Create Template dialog box.

The illustration below shows the completed template:
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Section Summary:
♦ By using the vector offset constraint the shoulders will maintain the same slope as the 

overlay section.

♦ Once the right click options of Mirror and Reflect are turned on, they remain active 
until they are turned off.

Lab 24.6 - Creating the Overlay Corridor

Finally, a corridor is constructed using the alignments and template developed earlier.

Section Objectives:

♦ Create a corridor for the SH 86 alignment.

♦ Add a template drop using the widening and overlay template.

♦ Add point controls using the edge of pavement and SH 86 alignments.

♦ Review the results in Roadway Designer.

♦ Add a superelevation solution to the corridor.

♦ Refine the corridor using Cross Slope Optimization.

♦ Add a Leveling course to the template.

♦ Add a stripping course to the template.

♦ Add vertical alignment adjustments.

♦ Regress the refined vertical alignment.

♦ Apply the regressed vertical alignment to the corridor.

This corridor will contain a single template drop along with point controls. Horizontal controls 
will define the width of the overlay section. Vertical controls will be generated initially through 
superelevation and ultimately refined by cross slope optimization. Overlay and stripping 
criteria will be defined to adjust and smooth the vertical alignment.

1. From the InRoads menu bar, select Modeler > Roadway Designer.

2. If not already set, toggle Display Mode: to Normal.

3. In the Roadway Designer dialog box, select Corridor > Corridor Management from 
the menu bar.

4. In the Manage Corridors dialog box, key in Overlay Project for the Name.

5. Set Surface Symbology: D_ROADWAY-Asphalt

6. Set Horizontal Alignment: SH 86

7. Set Vertical Alignment: SH 86_Existing-V

8. Toggle on Station Limits.

9. Key in 205+00.00 for the Start station.

10. Key in 259+00.00 for the Stop station.
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11. <D>Add then <D> Close to dismiss the dialog box.

12. In the Roadway Designer dialog box, select Corridor > Template Drops from the menu 
bar.

13. In the Template Drops dialog box, key in 25.00 for the Interval.

14. Expand the C:\Projects\12345\Design\InRoads\DES12345_Templates-
Overlay template library to show the contents of the 1 - Templates folder.

15. Highlight the 12345_Overlay template.

16. <D> the Add button then <D> the Close button to dismiss the Template Drops dialog 
box.

The template is now displayed in the cross section view. Next, point controls are added to make 
the design template match the width of the existing roadway. 
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Lab 24.7 - Horizontal Point Controls

Before assigning horizontal controls to the template points, for visual reference, display the 
controlling elements in the roadway designer views.

1. In the Roadway Designer dialog box, select Corridor > Display References

Add the alignments Lt_EOP and Rt_EOP created earlier in this chapter that represent the left 
and right edges of existing pavement.

2. Add alignments Lt_EOP and Rt_EOP as displayed references.

3. <D> the Add button then <D> the Close button to dismiss the Display References dialog 
box.

The alignments are displayed in Roadway Designer.

4. From the Roadway Designer menu bar, select Corridor > Point Controls.

5. In the Point Controls dialog box, key in Horizontal location for right lane for the 
Control Description.
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6. Set the Point to RT_HMA_Lift1_Laneline-Top.

7. Toggle on Horizontal for the Mode.

8. Select Rt_EOP for the Horizontal Alignment.

9. <D> the Add button.

10. In the Point Controls dialog box, key in Horizontal location for Left lane for the 
Control Description.

11. Set the Point to LT_HMA_Lift1_Laneline-Top.

12. Select Lt_EOP for the Horizontal Alignment. 

13. Add Control Description: Horizontal location for left lane

14. <D> the Add button the <D> Close to dismiss the Point Controls dialog box.

This completes the corridor definition. Now the corridor can be reviewed in Roadway 
Designer.
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15. Scroll through the template drops using the station controls under the cross section view. 
Notice that the template width matches the horizontal location of the existing pavement.

The template has been constrained to match the width of the existing pavement. Next Cross 
Slope Optimization will be used to match the existing pavement cross slope. First 
superelevation control lines will be created. These superelevation control lines will be 
overwritten by new control lines developed using cross slope optimization.

16. Select Superelevation > Create Superelevation Wizard > Table from the 
Roadway Designer menu bar.

17. In the Table Wizard dialog box, <D> the  button to display the Open Superelevation 
Table dialog box.

18. Navigate to the C:\Workspace\Workspace‐CDOT_V8i\Standards‐Global\InRoads\ 
Superelevation Tables\AASHTO 2004\ folder.

 

19. Select 06-55.sup and <D> the Open button.
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20. <D> the Load Values From Table button.

The rate values are read from the table and updated for each horizontal curve set listed in 
the dialog box or highlighted.

21. <D> Next.

22. <D> the ADD button on the Superelevation Section Definitions pane. This displays the 
Add Superelevation Section dialog box.

 

23. Use the drop down menu or the target  button to select the Crown Point: 
HMA_Lift1_Centerline.
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24. Use the drop down menu or the target button to select the Left Range Point: 
LT_ HMA_Lift1_Laneline.

25. Use the drop down menu or the target button to select the Right Range Point: 
RT_HMA_Lift1_Laneline.

26. <D> OK.

27. <D> Next on the Superelevation Section Definitions pane. This displays the 
Superelevation Controls pane.

28. <D> Finish. This completes the development of the initial superelevation control lines.
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29. Review the computed superelevation in the Roadway Designer views and by setting the 
Display Mode to Superelevation.

Lab 24.8 - Optimize the Overlay Corridor

Now Cross Slope Optimization will be used to relate the template cross slopes to the existing 
pavement cross slopes.

1. In Roadway Designer toggle on Display Mode: Overlay.

Note: The display mode must be set to overlay to access the overlay tools.

2. Select Overlay Tools>Cross Slope Optimization.

3. In the Existing Ground Cross Slope Definition area, set the Existing Type to Alignment.

4. Set the Pivot Alignment to SH_86.

5. Set the Superelevated Alignment to Lt_EOP.

6. In the Design Cross Slope Definition area,select Control Line for the Design Type.

7. Select Section1 HMA_Lift1_Centerline-Top-LT_HMA_Lift1_Laneline-Top for the 
Control Line.

8. In the Optimization Parameters area, key in 0.00% for the Slope Tolerance.
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9. <D> Calculate Correction a solution is presented. 

Note the values in columns Ground Slope & Corrected Slope match indicating the design cross 
slope now matches existing conditions.

10. Select Section Name: Section 1

11. Key in for Control Line: Slope-Opt_Lt_Laneline
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12. <D> Create.  New point controls are created for the left lane.

13. <D> Close and review the new control line in the superelevation view. 
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14. Repeat Overlay Tools > Cross Slope Optimization to develop the solution for the 
right side of the roadway using the following input changes:

Enter the following criteria to define the .

15. In the Existing Ground Cross Slope Definition area, select  Alignment for the Existing 
Type.

16. Select SH 86 for the  Pivot Alignment.

17. Select Rt_EOP for the Superelevated Alignment.

In the Design Cross Slope Definition area, select Control Line for the Design Type.

18. Select Section1 HMA_Lift1_Centerline-Top-RT_HMA_Lift1_Laneline-Top for the 
Control Line.

19. <D> the Calculate Correction button.

20. In the New Control Line area, select Section 1 for the Section Name.

21. Key in for Slope-Opt_Rt_Laneline for the Control Line Name.

22. <D> Create.  New point controls are created for the right lane.

23. <D> Close to dismiss the Cross Slope Optimization dialog.

24. Select Corridor > Point Controls

The original two superelevation control lines should be automatically disabled. The remaining 
four controls effect with and slope of the template.

25. Review the new control lines in the superelevation view.

26. From the Roadway Designer menu bar, select File > Save.
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Lab 24.9 - Corridor Review and Vertical Adjustment

Currently the corridor has horizontal and slope controls relative to existing conditions. In 
subsequent labs the corridor will be modified to adjust for the overlay thickness, pavement 
leveling and pavement stripping requirements. Prior to making those adjustments, review the 
current state of the corridor and related quantities.

1. In Roadway Designer toggle on Display Mode: Normal.

2. Scroll through the template drops and note the location of the template relative to existing 
conditions

It can be seen that the overlay falls almost entirely below the existing conditions. This will be 
addressed with overlay tools.

3. <D> Process All in Roadway Designer

4. Using the scroll buttons navigate to the last station.

5. From the Roadway Designer menu bar select Tools > Component Quantities to take a 
quick look at quantities and cost.

6. In the D_HMA_Pvmt row, key in 36.25 in the Unit Cost column. The cost of the overlay 
is all we will address for this lab.

7. Note the Total Cost/Material _____________________________.

A combination of changes to the design will be made by adjusting the vertical grade, adding 
pavement stripping and pavement leveling components to the template to determine the 
optimum solution.

8. <D> Close to dismiss the Component Quantities dialog box.
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9.  Select Tools > Options in the Roadway Designer dialog box, toggle on Cut and Fill 
Graphics.

10. <D> OK to accept the changes and dismiss the dialog box.

Review the limits of cut, note that the overlay is almost entirely in cut because the design 
profile is coincident with the existing grade. Overlay tools will be used to make adjustments to 
the design profile alignment.

11. Select Tools > Options in the Roadway Designer dialog box, toggle off Cut and Fill 
Graphics.

12. <D> OK to accept the changes and dismiss the dialog box.

13. In Roadway Designer toggle on Display Mode: Overlay.

14. Select Overlay Tools > Vertical Adjustment Settings.

15. Toggle on Use Minimum Overlay and key in 2” which will raise the profile alignment 
by an amount equal to the overlay pavement thickness.

16. Under Template Range set the Left Range to LT_HMA_Lift1_Laneline-Top.

17. Set the Right Range to RT_HMA_Lift1_Laneline-Top.

18. <D> OK 



Colorado Department of Transportation   Page 535

Labs for InRoads V8i LAB 24 - Widening and Overlay

19.  <D> Cancel to close the Vertical Overlay Adjustments Settings dialog box.

20. <D> Process All.

Between the template range points an evaluation is performed comparing the existing ground to  
the design template.  At template application stations the template is raised to maintain the 
minimum overlay thickness.  The value of the vertical adjustment at the centerline is displayed.

Note: It’s okay to toggle between Normal and Overlay display modes.  However the  
overlay adjustments are only reflected while the Overlay display mode is active.

Lab 24.10 - Creating a Pavement Leveling Component

A review of the overlay adjustments shows a gap area between the bottom of the asphalt 
overlay component and the existing ground.  This area will be addressed by adding a leveling 
component to the template.

1. Save and Close the Roadway Designer dialog box.

2. Open the Create Template dialog box and <D><D> on the template 12345-Overlay to 
open it for editing.
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3. <D> Add > Overlay/Stripping (component)

4. In the Current Component area, key in HMA_Leveling for the Name.

5. Select Follow Component for the Top option.

6. Select Follow Highest for the Bottom option.

7. Key in 6” for the Component Depth.

8. Set the Style to D_LEVELING-Asphalt.

9. Working from left to right, create the component by selecting the three points representing 
the bottom of the 2” overlay compliment.

10. <R> Finish

11. <D> Test to evaluate the added component.



Colorado Department of Transportation   Page 537

Labs for InRoads V8i LAB 24 - Widening and Overlay

Note: The option selected for Top option instructs the added component to follow or tie 
to the bottom of the 1” overlay asphalt component. The bottom option could have 
been set to follow surface (existing conditions) but by selecting follow highest a 
second leveling course could be added if a second leveling material is desired.  
Having done so the first leveling course will tie to the higher of the existing 
conditions or the second leveling course. In this exercise 6” should suffice for all 
leveling needs.

12. File > Save to save the template library.

13. <D> Close.

In Roadway Designer synchronize the revised template with the corridor. 

14. Open Roadway Designer.

15. <D> Corridor >Template Drops.

16. Highlight the template drop.

17. <D> Synchronize with Library.

18. <D> Close.

19. Review the overlay adjustments and the additional leveling course.

20. <D> Process All, in Roadway Designer.

21. Using the scroll buttons navigate to the last station.

22. From the Roadway Designer menu bar select Tools > Component Quantities to 
review quantities and cost.

23. On the D_LEVELING_Asphalt row, key in 32.00 for the Unit Cost/Material column.

24. Note the cost of the leveling course ____________________________.

25. <D> Close to dismiss the Component Quantities dialog box.
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Lab 24.11 - Creating a Pavement Stripping Component

Adding a pavement stripping component to the template can reduce the amount of leveling 
material required. Two items need to be addressed. First a vertical adjustment will be made to 
allow for a milling depth. Secondly a  component will be added to the template to quantify the 
amount of material milled.

1. From the Roadway Designer menu bar select Overlay Tools > Vertical Overlay 
Adjustment Settings.

2. Toggle on Maximum Milling and key-in 1”.

3. <D> OK to close the Vertical Overlay Adjustment Settings dialog box.

4. <D> Process All, in Roadway Designer

Review the overlay/leveling results

5. Save and Close the Roadway Designer dialog box.

6. Open the Create Template dialog box and <D><D> on template 12345-Overlay to open it 
for editing.

7. <D> Add > Overlay/Stripping (component)

8. In the Current Component area, key-in D_Milling for the Name.
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9. Select Follow Surface for the Top option.

10. Select  Follow Component for the Bottom option.

11. Select  D_Milling for the Style.

12. Toggle on Stripping Component.

13. Create the component by selecting the three points representing the bottom of the 1” 
overlay component, from left to right.

14. <R> Finish.

Note: The component created has no depth however it’s application is controlled by a 
combination of settings in roadway designer overlay tools and the existing surface.  
Testing the component may display results that appear suspect but will function 
correctly.

15. Select File > Save to save the template library.

16. <D> Close

In Roadway Designer synchronize the revised template with the corridor. 

17. Open the Roadway Designer dialog box.

18. <D> Corridor > Template Drops.

19.  Highlight the template drop

20. <D> the Synchronize with Library button.

21. <D> Close.
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22. Review the overlay adjustments which should depict both leveling and stripping 
components.

Make a final check on quantities and associated costs.

23. <D> the Process All button, in Roadway Designer.

24. Using the scroll buttons navigate to the last station.

25. From the Roadway Designer menu bar select Tools > Component Quantities to 
review quantities and cost.

26. For the D_Milling unit cost key in $8.80

Next, compute the cost savings achieved by adding using the milling component to reduce the 
levelling material.

27. Add the Total Cost/Material for D_LEVELING-Asphalt and D_Milling.

D_LEVELING-Asphalt _____________ + D_Milling_____________ = ______________

28. Compare the Total Cost/Material for the leveling course  here with that noted on page 85.

Cost from pg. 85_____________ - Cost above _____________ = Savings______________

29. <D> Close the Component Quantities dialog box.

30. To find the precise planner area of pavement milling select Tools > Milling Report

31. For the XML report Select folder Milling and the style sheet: 
RoadwayDesignMillingReport.xsl

32. Close the Bentley Civil Report Browser and Close the Component Quantities dialog 
box.
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Lab 24.12 - Creating the Regressed Vertical Alignment

The adjustments made to the vertical alignment through the use of overlay tools are temporarily 
stored in memory until applied to the corridor.

In Roadway Designer (in overlay display mode) the upper-right quadrant of the dialog displays 
two lines.  These lines represent the original vertical alignment used to define the corridor.  A 
second line, shown in red, displays the ideal vertical alignment as defined by the Vertical 
Adjustment Settings.  This optimized alignment can be applied to the corridor as is or it can be 
smoothed, or regressed, within user defined tolerances to develop a ‘best fit’ alignment.

1. From the Roadway Designer menu bar, select Overlay Tools > Smooth Adjusted 
Vertical Alignment

2. Key in 0.5” as the Tolerance.

3. Key in 12345_Smoothed for the Vertical Alignment Name.

4. <D> Apply.

5. <D> Close.

6. Select  Overlay Tools > Apply Adjusted Vertical Alignment.

7. Toggle on Apply Adjusted Vertical Alignment to Corridor.

8. Select ALG_OTHER_Vert for the Style.

9. <D> OK.

To verify the results:

10. Select Corridor  > Manage Corridors
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11. <D> on corridor Overlay Project, note the vertical alignment associated with the 
alignment. 

12. <D> Close to dismiss the Manage Corridors dialog box.

13. In Roadway Designer toggle on Display Mode: Normal.

14. Using the scroll buttons navigate through the template application locations to review the 
design.
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15. Select Tools > Component Quantities to see the  results using the smoothed vertical 
alignment.

16. <D> Close to dismiss the Component Quantities dialog box.

17. Select File > Save to write the roadway definitions to 12345_DES_Overlay.ird

18. <D> Close to dismiss the Roadway Designer dialog box.

19. Exit InRoads and MicroStation.

Chapter Summary:

 Point controls can be used to match the existing cross slope of the road.

 Surface features can be used to create point control alignments.

 Be aware that other features may reside inside of the edge of pavement which could cause 
problems when modeling the corridor.

 If the edge of pavement is to be saw cut prior to widening, a horizontal offset can be 
defined when point controls are created.

 Slope optimization can also be used to develop a design relative to existing conditions.

 Superelevation is used to develop a control line that can be overridden by cross slope 
optimization.

 Using cross slope optimization can be used to rehabilitate existing pavement cross slopes.

 Vertical alignments can be adjusted for overlay and/or milling requirements.

 There are new template components for overlay and milling (stripping).

 Component quantities can be calculated as a design progresses.
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